[wingide-users] Wing IDE 2.0.2 Released

Wing IDE Support support at wingware.com
Mon Mar 14 11:01:36 EST 2005


On Sun, 13 Mar 2005, Brian Almond wrote:
> Great work, it looks like quite a long list of enhancements and fixes!
> 
> I wanted to report one issue I did have in upgrading:
> 
> The Wing 2.0.2 installer appeared to uninstall 2.0.1 for me and
> install 2.0.2 completely, but I was getting an error when trying to
> open python files within wing.  I would receive an "Error executing
> command .internal.gui.open_gui" message.  The tab for the file would
> actually be created, but the editor component of the tab would not be
> created.  (ie. the tab had no controls on it)
> 
> I then uninstalled Wing, deleted the Wing folder entirely and
> reinstalled.  That took care of the issue.  Apparently something from
> the old version was hanging around and causing trouble.  Tomorrow I'll
> put in some quality time with Wing at work and get a better feel for
> 2.0.2.

It looks like patch #01 for Wing 2.0.1 causes this problem 
because it had to be made outside of the patch manager due
to a bug in the patch manager itself.  Sorry about that --
hopefully this is the last time we'll have unclean upgrades
due to patches, since the patch manager has been fixed in
2.0.2.

- Stephan



More information about the wingide-users mailing list