[wingide-users] New problems with Zope, unit tests and WingIDE

Wingware Support support at wingware.com
Tue Apr 12 12:27:47 EDT 2005


On Tue, 12 Apr 2005, Lennart Regebro wrote:
> On Apr 11, 2005 11:45 PM, Wingware Support <support at wingware.com> wrote:
> > The Products directories that Wing finds by parsing etc/zope.conf
> > are not added to the path because Zope should be doing that
> > internally.  For the unit tests, if they run from the command
> > line, they should also run from Wing w/o us automagically adding
> > anything to the path.
> 
> Well, they aren't run from the command line, typically, but with a
> test runner, that of course does all the necessary magic...
> 
> Anyway, my old instance where this was working is gone, so I can't
> figure out why it was working, or if I was just hallucinating. ;) I
> need to find a way to run single test-files without a test runner, or
> I need to figure out how to run the testrunner from within WingIDE. I
> have no idea how to do any of these things at the moment.

Most likely, adding items to the Python Path and possibly 
Environment in Project Properties should do it.  I don't
know much about the test runner but can't you just replicate
the command line you send to it?  See Run Arguments in the 
Debug tab of File Properties.

If you can get that working and want to run individual tests,
setting a breakpoint when running the test runner and looking at
sys.path and os.environ may tell you what you need to set in
Wing's project properties.

- Stephan


More information about the wingide-users mailing list