[wingide-users] New problems with Zope, unit tests and WingIDE

Wingware Support support at wingware.com
Fri Apr 8 13:29:30 EDT 2005


On Fri, 8 Apr 2005, Lennart Regebro wrote:
> I got unit tests working under WingIDE before, but now they stopped working.
> 
> There are two differences: I updgraded WingIDE to 2.0.2 (it was 2.0.1
> before I think) and Zope is now installed as default, that is with
> separate SOFTWARE_HOME and INSTANCE_HOME. (This is probably the reason
> why it doesn't work).

Actually, Wing 2.0.2 supports separate zope + instance 
directories.  If you turn on the Zope support in project
preferences and point Wing at the instance, Wing reads
the etc/zope.conf file to find the zope home and other
products directories.

Normally, you should not have to have anything extra
in your Project Properties' Python Path at this point.

One thing that's new is that WingDBG by default will
enabled script debugging (replaces the old script
debugging patch and ScriptDebugging hot patch product).
You might try disabling that (first choice in the ZMI
config page for WingDBG) in case it's causing a problem.

Also, be sure you upgrade WingDBG to 2.0.2, in case you
haven't done that.

If that doesn't help, please send us a recursive directory
listing of the relevant areas plus your project file so we
can try to help w/ the configuration.

Thanks,

Stephan Deibel

--
Wingware
Wing IDE for Python
Advancing Software Development

www.wingware.com


More information about the wingide-users mailing list