Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Remote Debugging Problems

Wing IDE Support support at wingide.com
06 Mar 2003 14:59:57 -0500


I suspect the file mapping is not set up correctly for some reason.  Is
the directory mounted on Z: the /usr/local/zope directory?  You can also
try pausing the Zope debug session from the IDE after the debugger
connects and the program is running.  The IDE should show the run
position in one of the WingDBG product files.

Also, you'll want to set the python executable in the IDE to a Windows
binary.  The IDE runs the executable in order to determine the version
of python being used.  I doubt this is causing the remote debugging
problem, but you'll probably want to change it.

Hope this helps,

John

On Fri, 2003-03-07 at 14:04, Greg Schlut wrote:
>    I am having a problem remote debugging my zope applications.  The 
> zope server runs redhat 7.1, and I would like to use a windows 2000 
> computer to do the debugging.  Wingide works fine when I debug from the 
> zope server, but when I use it on the windows 2000 machine wingide won't 
> do the remote debugging.  Can I use a windows wingide client to access 
> my linux zope server?  I am using samba to map my zope home directory to 
> drive z on my windows 2000 wingide host.  I can also see when I start 
> the wingide product, that wingide changes from Debugger: Ready and 
> listening to ---> Debugger: Program running [718 modules loaded].  This 
> part is good, my windows 2000 wingide is seeing the remote debugging 
> zope product.  When I then open my python code in the project and run 
> the url on the zope server port 50080, it doesn't stop a my breakpoints 
> or even debug.  What could be the problem?  I looks like the connection 
> to the zope server is fine, it just isn't debugging for some reason. 
> Below is my config.
> 
> 
> wingide preferences:
> debug.passive-listen=true
> debug.passive-hosts=('127.0.0.1', '192.168.53.8')
> debug.location-map{ '127.0.0.1':None, 
> '192.168.53.8':[('/usr/local/zope/Zope-2.6.0', 'file:Z:/Zope-2.6.0')], }
> 
> Properties configuration in wingide:
>   Python executable and path are set to my zope versions. 
> "Z:/Zope-2.6.0/bin/python" and "Z:/Zope-2.6.0/lib/python" respectively. 
> These are accessed through samba.
> 








Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements