Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Deprecated module 'rotor' when using Python 2.3b2

Wing IDE Support support at wingide.com
Thu, 17 Jul 2003 10:44:41 -0400 (EDT)


Hi,

On Thu, 17 Jul 2003, Richard Moseley wrote:
> /usr/local/lib/wingide/bin/2.3.0/opensource/schannel/securechannel.py:52: 
> DeprecationWarning: the rotor module uses an insecure algorithm and is 
> deprecated

This is a known problem when the debug process is running under Python
2.3.  It's harmless unless the extra output is screwing up your debug 
process.  Bugfix #13 fixes the problem:

http://wingide.com/support/downloads_list&version=1.1.9&section=bugfix

The rotor module was a place holder for real encryption on the debug
channel.  There hasn't been much request for running a more secure remote
debug connection, so we haven't done further work on this.

- Stephan





Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements