Archaeopteryx Software, Inc.
Take Flight!Search

Wing IDE
About Us
Open Source

 Advanced Search

[wingide-users] Deprecated module 'rotor' when using Python 2.3b2

Richard Moseley richard.moseley at
Thu, 17 Jul 2003 10:03:05 +0100

Since I have compiled Python 2.3b2, I receive the following message whenever I 
start to debug a program:

DeprecationWarning: the rotor module uses an insecure algorithm and is 

I get these messages when I use my laptop to run wingide but by work machine 
as the screen, the warnings come up on the xterm session that I leave up.

Apart from this, I've use wingide for a number of years now, though probably 
not as some others on this list, I generally only use to track down problems 
that would otherwise require excessive 'print's.

Richard Moseley

Run by Mailman v 2.0.8

Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements