Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Can't print from Wing

Stephan R.A. Deibel sdeibel@wingide.com
Fri, 31 May 2002 08:32:23 -0400 (EDT)


On Fri, 31 May 2002, richard terry wrote:
> I can't print out the source code, getting a variety of messages the last one
> being 'pdf to postscript conversion failed.'

What version of Wing IDE are you using?  There were some problems on
some Linuxes that were fixed in version 1.1.4.

Also, you do need to install Acrobat Reader and make sure it's on your
path, in order for fancier printing to work on Linux.  If you want to
avoid this then set the following preference and restart Wing:

edit.print-python-as-text= { 'posix': 1, 'win32': 'unused' }

You can also alter the print creation and spooling by changing these
prefs:

edit.text-print-cmd={ 'posix': 'enscript --pretty-print %s', 'win32': 'unused' }
edit.print-spool-cmd={ 'posix': 'lpr %s', 'win32': 'unused' }

W/o acrobat and with the above pref set, you don't get syntax highlighting
in Python, however (but still will in things that your version of enscript
and pretty print).

Hope that helps,

- Stephan






Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements