Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Wing does not attach to the remote process

Stephan R.A. Deibel sdeibel@wingide.com
Sun, 16 Jun 2002 11:41:59 -0400 (EDT)


On Sun, 16 Jun 2002, Robert Rottermann wrote:
> Good morning (or what ever),
> I try to debug a zope session on a Linux box with my NT2000 based Wing.
> However Wing (the one on NT2000) does not see (change to "running") the remote process.
>
> This is what I have done:
> - installed wing on the remote computer
> - copied wingdbstub to a directory in the import path
> - replaced ZRendevous.py
> - changed the start-up script to use -t 0
> - changed wingdbstub as follows
>     kWingHostPort = '192.168.1.210:50005'
> - changed preferences
>     debug.passive-hosts=('127.0.0.1','192.168.1.210')

Did you also include wingdbstub in z2.py or elsewhere in code that is
reached?  This file is also patched in our Zope patch.

Also, copy the file .wingdebugpw from WINGHOME\profiles\[username]
on your NT machine to ~/.wingide/.wingdebugpw on your Linux machine.
Hmm, this step seems to be under-documented in the manual.

Also, you'll need to set up file sharing and a file location map
as described in section 6.14.4 of the Wing IDE 1.1.4 manual:

http://wingide.com/psupport/wingide-1.1/node7.html#SECTION007144000000000000000

(this isn't needed for the connection to happen, but is if you want
to do anything useful like step through code or stop at breakpoints)

If none of this helps, set kSilent=0 in wingdbstub on Linux and set
preference debug.kVerbose=1 on NT and run console-wing instead of wing
from the command line to see diagnostic output.  It's cryptic but if you
send it to support@wingide.com we should be able to figure out what you
need to try.

- Stephan






Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements