Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] "The debug process never connected" message -- Solved

Stephen Boulet stephen@theboulets.net
Wed, 24 Jul 2002 21:21:25 -0500


Just to let you know, this ftplib script works fine on my installation, b=
ut=20
wingide still has problems connecting its debug process.

This solved the problem for me:

   rm -f `find /usr/lib/python2.2 -name "*socket*"`
   emerge python # a gentoo command to compile python from source

So it seems that some file with 'socket' in its name is the culprit. The=20
choices are:

/usr/lib/python2.2/test/output/test_socket
/usr/lib/python2.2/test/test_socket.py
/usr/lib/python2.2/test/test_socket_ssl.py
/usr/lib/python2.2/test/test_socketserver.py
/usr/lib/python2.2/test/test_socket.pyc
/usr/lib/python2.2/test/test_socket_ssl.pyc
/usr/lib/python2.2/test/test_socket.pyo
/usr/lib/python2.2/test/test_socket_ssl.pyo
/usr/lib/python2.2/test/test_socketserver.pyo
/usr/lib/python2.2/test/test_socketserver.pyc
/usr/lib/python2.2/socket.py
/usr/lib/python2.2/lib-dynload/_socket.so
/usr/lib/python2.2/socket.pyc
/usr/lib/python2.2/socket.pyo

-- Stephen

On Tuesday 23 July 2002 08:31 am, you wrote:
> On Tue, 23 Jul 2002, Stephen Boulet wrote:
> > Can you give me another example of a python program using sockets tha=
t
> > might be affected by this? Thanks.
>
> Here's a real simple one that lists the top level of our ftp site:
>
> import ftplib
> ftp =3D ftplib.FTP('wingide.com')
> ftp.login()
> ftp.retrlines('LIST')
> ftp.quit()
>
> It's entirely possible that only specific sockets calls are broken by
> the update (since the sockets module is built-in), so the above may
> still work.  It would be interested to see if it does, and then go
> from there to try to craft a test that shows the problem.
>
> - Stephan
>
> -----------------------------------------------------------------------=
-
> Wing IDE for Python                          Archaeopteryx Software, In=
c
> www.wingide.com                              Take Flight!






Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements