Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Hanging whenever I type "import" !! -- SOLVED

Wing IDE Support support@wingide.com
Thu, 4 Apr 2002 11:32:20 -0500 (EST)


On Thu, 4 Apr 2002 Nigel.Head@esa.int wrote:
> 2) Uninstall Python 2.2
>
> 3) Reboot
>
> 4) Delete remaining \python22 directory, with all remaining contents

I'll bet upgrading Python (and perhaps other things, like Wing IDE) fails
sometimes on win98 because some files are not replaced because the OS
thinks they are in use, either because they actually are or because the OS
is confused.  Just a wild guess, but it seems consistent with what we've
seen, although I can't explain why the installer doesn't complain.  I
don't think is a file modification date problem, from past examples of
this kind of trouble, but I am not 100% sure.

> Deduction -- there was something wrong with the python install .... although
> what I don't know as I recall that I did it exactly the same last time except
> that I was uninstalling 2.1 instead of 2.2 and the scripts in question worked
> just fine if I ran them w/out Wing.  I have my suspicions that the words "dll"
> and "hell" may figure in this somewhere though .... strangely the problem
> originally arose before I even attempted the python upgrade in the first place
> (so perhaps there is a 3rd player in this dll hell game here somewhere. I have a
> Zope binary install [dormant] on the system too, which may also have poked about
> in \windows\system somewhere).

Since Wing adds TCP/IP sockets and other stuff to the debug process, it
exersizes more code and can bring out problems on flaky systems, so it
isn't surprizing that your debug code worked outside of the debugger.
We've seen this exact problem several times before on win98, each time the
soln is to uninstall, manually remove files, and reinstall Python.

For the record, can you reply to this email and post which exact version
of Win98 you're using?  It is win98se or not?  So far evidence points to
this being specific to win98 non-se but I am not sure about that.

BTW, I suspect it's not DLL related from what you describe, but rather
just a result of a mishmash of files, some from Python 2.1, some from
Python 2.2... but I could be wrong.

- Stephan

------------------------------------------------------------------------
Wing IDE for Python                          Archaeopteryx Software, Inc
www.wingide.com                              Take Flight!







Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements