Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] follow up to : Problem attaching to Zope

Stephan R.A. Deibel sdeibel@archaeopteryx.com
Sun, 13 May 2001 19:52:59 -0400 (EDT)


Hi,

This is probably due to a difference in winsock vs. sockets on Linux, or a
change since Zope 2.3.0 that broke something in our code. We install the
debugger's socket into the Zope asyncore and it looks like that might not
be working as it should on Windows and/or with Zope version 2.3.2 (3.3.2
doesn't exist yet, so I'm assuming 2.3.2 is what you meant ;).

We'll look into it and will post a fix as soon as we can.

Thanks for reporting this.

- Stephan

------------------------------------------------------------------------
Archaeopteryx Software, Inc.                        Wing IDE for Python 
www.archaeopteryx.com                               Take Flight!



On Sun, 13 May 2001, Robert Rottermann wrote:

> Hi there,
> here some more facts I discovered:
> When Zope is started
> Wing status changes to Debugger: Programm running
> However as soon an breakpoint is hit the following output is created in the
> dosbox from where I started Zope:
> 
> 2001-05-13T19:32:36 ERROR(200)
> ZServer uncaptured python exception, closing channel
>   <zhttp_channel connected 127.0.0.1:1870 at 19e9dd8 channel#: 30
> requests:2>
>   (socket.error:(10054, 'winsock error')
> [K:\Programme\zope\ZServer\medusa\asynchat.py|initiate_send|211]
> [K:\Programme\zope\ZServer\medusa\http_server.py|send|399]
> [K:\Programme\zope\ZServer\medusa\asyncore.py|send|282])
> 
> Thanks for your time
> Robert
> 
> ----- Original Message -----
> From: Robert Rottermann
> To: wingide-users@archaeopteryx.com
> Sent: Sunday, May 13, 2001 9:26 PM
> Subject: Problem attaching to Zope
> 
> 
> Hi there,
> 
> I today downloaded the 1.1b5 Trial version of Wing.
> Performing the test with the wingTest product works as detailled in the
> tutorial.
> However I can not attach to Zope or have a breakpoint hit from Zope.
> I have z2.py adapted as outlined in the setup.
> 
> Wing says Debugger: Reddy and listening
> 
> When I try to attach to a running process I get the following error:
> 
> Debugging stopped Unexpetedly:
> Runtime failure details:
> Exception: socket error
> Value=(10054, 'winsock error')
> Traceback:
> File "/src/ide/bin\1.5.2\src\debug\server\netproxy.pyo", line 1072 in
> _SendCommand
> File "/src/ide/bin\1.5.2\opensource\schannel\securechannel.pyo", line 384 in
> ReceivePacket
>  .. line 501 in __RedRawPacket
> .. line 528 in __InternalReadRawPacket
> File "<string>", line 1, in recv
> 
> My Environment:
> Windows 2000
> Zope 3.3.2
> Your help would be very much appreciated.
> Robert
> 
> _________________________________________________
> Archaeopteryx Software, Inc.
> Wing IDE discussion list
> http://archaeopteryx.com/mailman/listinfo/wingide-users
> 






Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements