Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Problem attaching to Zope

Robert Rottermann robert@rocad.ch
Sun, 13 May 2001 21:26:08 +0200


This is a multi-part message in MIME format.

------=_NextPart_000_003C_01C0DBF3.52EBE0E0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Hi there,

I today downloaded the 1.1b5 Trial version of Wing.
Performing the test with the wingTest product works as detailled in the =
tutorial.
However I can not attach to Zope or have a breakpoint hit from Zope.
I have z2.py adapted as outlined in the setup.

Wing says Debugger: Reddy and listening

When I try to attach to a running process I get the following error:

Debugging stopped Unexpetedly:
Runtime failure details:
Exception: socket error
Value=3D(10054, 'winsock error')
Traceback:
File "/src/ide/bin\1.5.2\src\debug\server\netproxy.pyo", line 1072 in =
_SendCommand
File "/src/ide/bin\1.5.2\opensource\schannel\securechannel.pyo", line =
384 in ReceivePacket
 .. line 501 in __RedRawPacket
.. line 528 in __InternalReadRawPacket
File "<string>", line 1, in recv

My Environment:
Windows 2000
Zope 3.3.2
Your help would be very much appreciated.
Robert

------=_NextPart_000_003C_01C0DBF3.52EBE0E0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content=3D"text/html; charset=3Diso-8859-1" =
http-equiv=3DContent-Type>
<META content=3D"MSHTML 5.00.2920.0" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#c8e0d8>
<DIV><FONT face=3DArial size=3D2>Hi there,</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>I today downloaded the 1.1b5 Trial =
version of=20
Wing.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Performing the test with the wingTest =
product works=20
as detailled in the tutorial.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>However I can not attach to Zope or =
have a=20
breakpoint hit from Zope.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>I have z2.py adapted as outlined in the =

setup.</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Wing says Debugger: Reddy and=20
listening</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>When I try to attach to a running =
process I get the=20
following error:</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Debugging stopped =
Unexpetedly:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Runtime failure details:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Exception: socket error</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Value=3D(10054, 'winsock =
error')</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Traceback:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>File=20
"/src/ide/bin\1.5.2\src\debug\server\netproxy.pyo", line 1072 in=20
_SendCommand</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>File=20
"/src/ide/bin\1.5.2\opensource\schannel\securechannel.pyo", line 384 in=20
ReceivePacket</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>&nbsp;.. line 501 in =
__RedRawPacket</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>.. line 528 in =
__InternalReadRawPacket</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>File "&lt;string&gt;", line 1, in =
recv</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>My Environment:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Windows 2000</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Zope 3.3.2</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Your help would be very much=20
appreciated.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Robert</FONT></DIV></BODY></HTML>

------=_NextPart_000_003C_01C0DBF3.52EBE0E0--






Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements