Archaeopteryx Software, Inc.
Take Flight!Search

Home
Wing IDE
News
Support
About Us
Python
Open Source
Store

 Search:
 
 Advanced Search




[wingide-users] Can't find Python - plus "Bad command or filename"

Stephan R.A. Deibel sdeibel@archaeopteryx.com
Fri, 8 Jun 2001 16:52:20 -0400 (EDT)


On Fri, 8 Jun 2001 Nelson.Chenkin@seagate.com wrote:
> I just installed my 30-day trial version of WIngIDE for Windows. Looks
> pretty decent at first blush.
> 
> Two minor issues so far:
> 
> 1) Wing says that Python is not installed on my machine. But it is
> installed and it is in the path. If I open a DOS box I can just type
> "python" and I'm there. It's not installed in Program Files, but it is on
> my machine. When I debug I just tell Wing that Python Executable is
> "python" and path is use environment, and its happy. But maybe that message
> I get is related to the second item:
> 
> 2) While running Wing, the Windows DOS box used by Wing is filling up with
> "Bad command or filename" messages. Each time I debug I get another
> message.
> 
> Any clues?

Yes, these are related.  This should be harmless once you've pointed Wing
to python and will go away in 1.1b6 which we hope to release next week.  
We couldn't do a patch to 1.1b5 because this fix was too mixed up with
other work that's still in progress.

If it doesn't go away, please let us know.  We've run into some very odd
problems in finding and interogating the Python installation on different
Windows variants and want to be sure we get them all fixed before 1.1
final.

Thanks very much for the report.

- Stephan







Run by Mailman v 2.0.8


Copyright (c) 2000-2002, Archaeopteryx Software, Inc.
Legal Statements